Backing up shared folders


Backing up shared folders as source does not work.

It works normal till the end and at the end gives as ‘Fatial error file not found’
Some thing like that

restic backup //

Has anyone tried & got success

A log output will be more helpful for someone to help diagnose. However, keep in mind this bug which affects restores in Windows when backing up via UNC paths:

command for backup
restic_0.9.2_windows_amd64.exe -r \\Restic --hostname SEAGATE backup \\folder

Error at the end
Fatal: unable to save snapshot: Lstat: CreateFile \?\C:\Users\Administrator\ The system cannot find the file specified.

Have you tried using the drive letter to access the share?

Something like this (replace F with your drive letter):
restic_0.9.2_windows_amd64.exe -r F:\Restic --hostname SEAGATE backup F:\folder

A command like this works fine. Only network path fails. :slight_smile:

I want to backup my nas box this way

Just to clarify, are you specifying network paths with \ at the start? Like \ip\path (your example only shows single slashes)?

Ya it’s double slashes…

Backups run till the end and give out that error.
In this case around 35 gb
I need to purge the repository later. It than reduces around 24 gb.

The solution was to use a slash at the end like //

But the new problem is restoration failure completely