Xattr.list permission denied

I have a couple of CIFS mounts setup via systemd. These are automounted on demand - as shown below they are read-only and only mounted for access by restic. The option line is:


my exclude file is:

/mnt/cifs/**/System\ Volume\ Information

I had thought this would exclude System Volume Information from restic processing - but I still get:

error: NodeFromFileInfo: Listxattr: xattr.list /mnt/cifs/w2k3/System Volume Information : permission denied

Is this something I can fix by a different exclude? Different mount options? Or anything else?

The quoting in your excludes file is wrong (the lines are suitably quotred for specifying in a shell command), see https://restic.readthedocs.io/en/v0.9.6/040_backup.html#excluding-files for an explanation.

The following should work.

/mnt/cifs/**/System Volume Information

Thank you for the correction. It also helps when I actually specify the exclude file in my command line…