Wrong password or no key found on Scaleway Object Store


as alluded to in the title, I receive “wrong password or no key found” error messages when I try to create backups.

My System:
Scaleway VM
Ubuntu 18.04
Restic 0.11.0 from the github release page

What I tried so far:
Set up a new Repo on a S3 compatible storage

restic -r s3:https://url.s3.fr-par.scw.cloud/restic --verbose init

Entered a password, S3 storage contains a folder “restic” with a sub-fulder keys and a file “config”. the keys folder contains a file with a generated name (looks like a hash).

Try to create a backup

restic -r s3:https://url.s3.fr-par.scw.cloud/restic backup <some-directory> --verbose

Restic responds with

open repository
Fatal: wrong password or no key found

I tried the same thing with the password exported as RESTIC_PASSWORD env. As expected the password prompt was not shown anymore and new config and key files were generated (I did clean-up the storage between attempts). The result with the Password env was the same as before.

open repository
Fatal: wrong password or no key found

Did I miss any important steps? Are there any local files that might interfere with creating a new repo? Is there an issue when working with Scaleway Object Store?

[Edit] Formatting and removed some private info

Please have a look at Fatal: wrong password or no key found - Even after init · Issue #2971 · restic/restic · GitHub . There it looks like s3:https://s3.fr-par.scw.cloud/<url>/restic should work.

Thank you for your response. The solution in the linked ticked worked for me.