Why is the backup so big?

I’ve used restic for first time.
I tried to backup up some dirs on my server and on the server is only used 8.1 gb of disk. Restic repo after backuped up is about 367gb. Why so big?

on the server

df -h /
Filesystem      Size  Used Avail Use% Mounted on
/dev/md2       1007G  8.0G  948G   1% /

restic repo after first backup

/home/restic-repo > du -hs .
367G    .

full command

export RESTIC_REPOSITORY=sftp:restic-box1:/home/restic-repo
export RESTIC_PASSWORD=secret

/home/user/bin/restic backup /usr/local/bin
/home/user/bin/restic backup /etc
/home/user/bin/restic backup /home/user
/home/user/bin/restic backup /home/mail
/home/user/bin/restic backup /home/vmail

Please provide the logs from the backup runs, I mean the output from them. This will show relevant data.

It seems very unlikely that restic somehow backed up 8.1 GB and ended up storing 367 GB. There is some other explanation to what you are experiencing.

Unfortunately, I don’t have any logs from backup runs.
But I run restic stats

restic -r sftp:restic-box1:/home/restic-repo stats
enter password for repository: 
repository e00753f1 opened (version 2, compression level auto)
Stats in restore-size mode:
     Snapshots processed:  5
        Total File Count:  7009
              Total Size:  395.037 GiB

It looks really strange
I think I’m doing something wrong, but I don’t understand what exactly.

Perhaps you simply did back up that much data :slight_smile:

You should look at what you backed up, what filesystem it is, etc. Perhaps there’s a bunch of links to snapshots that in total make up 395 GB.

Yes, my fault. the home dir is actually on the another partition of disk and it much bigger than 8gb :slight_smile: sorry.

Great! :smiley: