What is the trick to globbing?

Novice user. I’ve read through the docs and I think the answer must be simple, but it’s eluding me.

Running restic 0.15.0 on Linux. I want to back up every file beginning with .e in my home directory. I’m trying various invocations like the following, but it does not seem to want to include those dotfiles in the backup.

> restic backup  /home/eater/.e* 
...
start scan on [/home/eater/.electron /home/eater/.electrum /home/eater/.emerald /home/eater/.enhancd /home/eater/.esd_auth /home/eater/.ether /home/eater/.expo]
start backup on [/home/eater/.electron /home/eater/.electrum /home/eater/.emerald /home/eater/.enhancd /home/eater/.esd_auth /home/eater/.ether /home/eater/.expo]
scan finished in 1.628s: 0 files, 0 B

Files:           0 new,     0 changed,     0 unmodified
Dirs:            0 new,     2 changed,     0 unmodified
Data Blobs:      0 new
Tree Blobs:      2 new
Added to the repository: 745 B (883 B stored)

processed 0 files, 0 B in 0:12
snapshot 185d5d1e saved

> restic ls latest 

repository 4fe632bb opened (version 1)
snapshot 185d5d1e of [/home/eater/.electron /home/eater/.electrum /home/eater/.emerald /home/eater/.enhancd /home/eater/.esd_auth /home/eater/.ether /home/eater/.expo] filtered by [] at 2023-01-22 12:01:17.390573792 -0500 EST):
/home
/home/eater

and the dotfiles are not in the snapshot.

That’s odd. How did you install restic? Apparently restic doesn’t see any files inside the home directory.

Is that what’s happening? I downloaded the stable binary release from github. I’ve tried executing it as the directory owner and in a sudo shell, same result.

I did a little more testing and it works fine with relative paths like ./.e* but not absolute paths.

That makes it tough to script. Is there a fix?

Meanwhile, if I try to back up ./.* it includes files and directories that begin with a dot as well as files and directories that do not begin with a dot.

That sounds rather weird, how exactly are you calling restic? Please create a DEBUG_LOG=debug.log restic backup [...]?

Sure … it contains a lot of identifying info so can I send it to you privately?