Using restic on a Synology DS220+

Is it possible to run restic on a Syno DS220+? I assumed my options are

  1. Place the binary directly into the file system and run restic off there OR
  2. Use a docker container and run restic off there with the source data mounted as a mapped volume to /source

Steps taken:

  • Figured that since I have the Intel Celeron J4025 with GeminiLake arch on my NAS, that an amd64 binary might be the best
  • I tried placing the amd64 binary into volume1/homes/myadminid/.local/bin and running off there, but restic was not a recognized command
  • I then tried extending PATH and pushing other env variables as per a comment from another post on the forum, but that didn’t work either
  • So I tried with docker and tried to both use the Synology GUI as well as docker compose but the container keeps stopping with no logs except help content. Mapped volume for source data was added.
  • I also tried the wrapped resticprofile using Docker, but ran into the same problem as above. Maybe because I think it uses the alpine image? Not sure at this point.

Any advise or help would be much appreciated. Thanks!