Unable to add 2FA

I’m unable to add 2FA to my Restic Forum account.
Each time I try I get old “Can only use code once”

I’ve tried both scanning the QR code, and manually entering the TFA Key.

Neither work.

Does anyone else have this issue?

Not sure what’s going on there. Do you have any tokens listed under the “Token-Based Authenticators” heading?

No I don’t have any tokenbs listend. I try to add them but this is the error I get:

Click Add Authenticator

That’s the error I get. It doesn’t matter if I scan the QR code, or if I grab the auth seed and paste it into bitwarden, I still get that error.

Thanks!

[I can’t attach multiple screenshots as I’m too new]

I would not be surprised if the “Each code can only be used once” message is generic and doesn’t necessarily apply to your specific case here. But that’s just a guess.

One possible reason between the code not working is time differences, as TOTP is sensitive to that. Based on the timestamps of forum posts it seems the forum is on track, but it might of course be a little bit off. I don’t have access to check the time on the server directly, but I would encourage you to make 100% sure that the time on the TOTP device you’re using is what it should be.

@fd0 Can you check the forum’s time? Not sure what else it could be.

Yea, my guess would be time as well - though it would seem odd that the forum’s underlying OS isn’t synced to something.

I’ve tried adding the codes both via my Phone (using the Android Bitwarden Client) and my Windows PC which is definetly synced to an NTP source so I’m sure I’m good from a clock PoV.

It’s not urgent obviously, I don’t think my restic forum account is going to be the top of a hackers priority, I mentioned it mostly to bring it to your attention.

Thanks!

Oh wow, thanks for the hint! The server’s time was indeed a bit off (about three minutes), I enabled systemd-timesyncd and now it should work :slight_smile:

@tjh can you retry please?

1 Like

@fd0 Works perfectly now - thank you.