Sftp works fine; restic does not

Evaluating restic and can’t get pass an issue creating a remote repository.
Backend is a Hetzner Storage Box. OS is Windows 10.

sftp -F /path/to/.ssh/config remote connect just fine.


Host remote
  HostName u123456-sub1.your-storagebox.de
  User u123456-sub1
  Port 23
  IdentityFile /path/to/.ssh/u123456-sub1-key
  IdentitiesOnly yes
  ServerAliveInterval 60
  ServerAliveCountMax 240

Tried a bunch of alternatives, with different results, but none of them succeeding.
Here’s the most basic one:

restic -r sftp::/restic-repo -o sftp.command="ssh remote -F /path/to/.ssh/config -s sftp" init

Result in:

enter password for new repository:
enter password again:
Fatal: create repository at sftp::/restic-repo failed: sftp: "Failure" (SSH_FX_FAILURE)

Any help would be greatly appreciated.

And, oh:

restic 0.12.1 compiled with go1.16.6 on windows/amd64

In Usability issue with sftp and sftp.command - #2 by fd0 the config file is specified before the remote host name. Does that work? Or does it help to add a trailing slash to the repository path?

Thanks for helping out, MichaelEischer.

I actually studied that exact post when I tried to get around it. All variations I found in there. :slight_smile: Not sure about a trailing slash though. Maybe that would work. :+1: