Restore is not working

I am having velero + restic in my cluster to test backup and restore.

I have NFS storageclass in my cluster for PV/PVC .
While I run backup . restic is taking backup properly , but having issue when I am restoring .

Velero: pod volume restore failed: error running restic restore, cmd=restic restore --repo=s3:https://s3endpoint/restic/mariadb --password-file=/tmp/credentials/velero/velero-restic-credentials-repository-password --cacert=/tmp/cacert-default2220251471 --cache-dir=/scratch/.cache/restic b9ab7ea0 --target=., stdout=restoring <Snapshot b9ab7ea0 of [/host_pods/15b-920f-4964-9078-0428bed2de72/volumes/] by root@velero> to .
, stderr=ignoring error for /.snapshot: UtimesNano: read-only file system
Fatal: There were 1 errors

Apparently the filesystem you’re restoring to is not writeable.

Ok. Do you think if i try to change PV/PVC to RWX can work or its on underline NFS persmisisons

I can’t say much about Kubernetes/Velero specifics, for that you’d have over at velero. All I can say is that the filesystem is mounted as read-only. Could also be the case that the filesystem in question is only exported as read-only over NFS.

Sorry for delay in response.

I am using the same nfs filesystem for backup and restore using k8up. I do not face any issue there.
but it seems restic is unable to restore while its performing the operation

I hve also tried only restic for backup and restore ,even no issue .