Restic with B2 Won't work with Firewall

I have a CentOS 7 server using restic to backup data to a B2 (Backblaze) server. B2 uses port 443 for it’s connection.

When I run restic with no firewall, it works great and backs up to B2 just fine. However, when I enable the firewall with port 443 open, it just hangs and never even connects to B2.

I ran:
lsof -i -P -n
and it shows:
restic 53047 root 3u IPv4 122320698 0t0 TCP xx.x.x.xx:40084->206.190.215.112:443 (ESTABLISHED)

My firewall is on the WAN Incoming and even though port 443 is open, it will not make a connection. Does anyone know what other ports need to be open for this to set up to function correctly?

Thanks

I’m not aware of any other port that would be required… except 53 for DNS, but pretty much nothing would be working without that.

Does your firewall log dropped/rejected packets? Maybe there would be a clue in the firewall logs.

Are you sure you allowed outgoing connections with destination port 443?

I note @tunamelt’s lsof shows the connection as ESTABLISHED with a B2 server on port 443, so I’d bet it’s not a DNS (ie port 53) block: if it was there would have been no name resolution to obtain the B2 server address depicted as ->206.190.215.112:443.

Also, I think port 443 is not being blocked either, because if it was, the connection would not be shown as ESTABLISHED (because the firewall would have blocked the initial TCP handshake).

@tunamelt, what firewall script are you running? if I were in your shoes I would enable blocked packet logging in the firewall rules and then look it up in the logs to see what is being blocked.

BTW, welcome to the forum! :wink:

Cheers,
– Durval.