Restic View Mount Files issue?

I was wondering if someone could shed some light on the issue im having. Currently have restic working perfect. What i wanted to is view the backup which i mounted it and only extract one file using winscp.
but im getting an error

General failure (server should provide error description).
Error code: 4
Error message from server: Failure

  Common reasons for the Error code 4 are:
 - Renaming a file to a name of already existing file.
- Creating a directory that already exists.
- Moving a remote file to a different filesystem (HDD).
- Uploading a file to a full filesystem (HDD).
 - Exceeding a user disk quota.

But the funny thing is that if I cp to another directory that file then open Winscp then i can copy it
any ideas?

This is the command i mount

        restic -r /media/backupdailyUSB mount /media/view

Thank you

Realized 2 things first i was running restic version 0.3 very old didnt not even noticed, I had to update go to 1.10 then restic to 0.8.3 after that i ran this

       restic -r /media/backupdailyUSB mount --owner-root /media/view

and it worked

Hope this helped for anyone else

Thank you

Glad you solved it! 0.3.0 is indeed very old, we’ve since fixed many bugs in the fuse code :slight_smile:

1 Like