Restic 0.13.1 Released

We’re proud to announce that restic 0.13.1 has been released today!

This is a companion discussion topic for the original entry at

Is the non-dev version string of latest master bumped?
I just built it and restic version still gives 0.13.0 :thinking:
Or should I try a branch?

Retry the build please, I forgot to push the version change commit to master, but now it’s there:

1 Like

Re-tried but no joy. Looks like it is using VERSION file though. Master branch still doesn’t have it (link). Changing this file manually and running make resulted with different number on version command. :eyes:

Yes, you’re right, I forgot the VERSION file. We tried something new with 0.13.1: I’ve split off a new branch from master, picked just a few commits that should go into 0.13.1 and then released from that branch.

The version command prints several things when built with go run build.go, among others the output of git describe. Since the tag v0.13.1 is not in the master branch, it’ll still show v0.13.0. I can’t change that right now.

Probably not ideal, but not too bad either, that’s the output for a build from master right now:

$ ./restic version
restic 0.13.1 (v0.13.0-70-g7f133a28) compiled with go1.18 on linux/amd64

Thanks for the explanation. I was building the binary by getting the master and determining the version by the command’s output. I guess I’ll need to check tags from now on.