Rest-server problems


#1

I am using restic successfully all over my mini-network at home, including Raspberry Pis.
I want to use rest-server on my Pi. I downloaded it and the go language, and compiled successfully. Here is what I am using:

rest-server 0.9.7 (v0.9.7-28-ga87d968) compiled with go1.11 on linux/arm

I appear to fire up the rest-server just fine:

=======================================
root@svcrpi:~# rest-server --no-auth --debug
Data directory: /tmp/restic
Authentication disabled
Private repositories disabled
Starting server on :8000

=======================================

In a different window #2 on the same node, and still as root, I try to show the snapshots through the REST interface.

=======================================
root@svcrpi:~# restic -r rest:http://localhost:8000/wd/restic/restic-other snapshots
Fatal: unable to open config file: does not exist
Is there a repository at the following location?
rest:http://localhost:8000/wd/restic/restic-other

=======================================

When I do that command, here’s what appears on window #1 (with the rest-server command):

=======================================
HEAD /wd/restic/restic-other/config

=======================================

Back in window #2, I can do a local restic command pointing at the same restic repo just fine:

=======================================
root@svcrpi:~# restic -r /wd/restic/restic-other snapshots
repository 3edbcbc1 opened successfully, password is correct
ID Time Host Tags Paths


cc9ccbc6 2018-10-22 16:14:17 STEVENLT5 c:
92b2eb7c 2018-10-25 08:10:00 STEVENLT5 c:
26f2ae33 2018-10-31 02:56:39 STEVENLT5 c:\


3 snapshots

=======================================

I believe I am missing something simple. Can anyone help me out?

Thanks - Steven


#2

You are: the default base directory for the REST server is /tmp/restic, it prints it during startup:

Data directory: /tmp/restic

I suggest you change the directory to /wd/restic:

# rest-server --no-auth --debug --path /wd/restic

Then you can access the repo like this:

# restic -r rest:http://localhost:8000/restic-other snapshots

#3

Thanks! I tried as you said, and it worked.

Just experimenting, I also tried this, and it didn’t work:

rest-server: --path /wd
remote repo reference: rest:http://localhost:8000/restic/restic-other

Does the system restrict nesting of the repo path to one level?

– Steven


#4

No, that’s should not be the case. I don’t know why it did not work.


#5

Is there any extra logging I can turn in rest-server to help figure out why?


#6

No, the debug options for the REST server are quite limited. If you like, you can try using rclone instead, which also offers the REST server for restic and has better debugging options: rclone serve restic, see here: https://rclone.org/commands/rclone_serve_restic/