Rest-server --private-repos issue

Hi, I’m testing rest server over https for my backups.
Following the documentation I created a new CA and then signed my server certificates using openssl, after that I copied the server key and certificate into the data directory as public_key and private_key files.

This is the syntax I’m using with docker to launch the container:

docker run \
-p 8000:8000 \
-v /mnt/backup/restic-rest:/data \
-e "OPTIONS=--private-repos" \
-e "OPTIONS=--tls" \
--name restic restic/rest-server

If I add the --tls option seems like rest server automatically turn off private repos, if I omit --tls private repos turn on.

Do you have any suggestions?

Thank you very much


Doesn’t your second -e "OPTIONS=--tls" override the first -e "OPTIONS=--private-repos"? Try putting both options in the same environment variable.

1 Like

You were totally right, now it works.

Thank you very much :slight_smile:

1 Like