Prune fails with 'data missing' - how to recreate data packs?

When I run this:

restic forget \
    --keep-daily        7 \
    --keep-weekly       4 \
    --keep-monthly      3 \
    --prune \
    -r $TARGET

I am getting error saying data is missing:

loading all snapshots...
finding data that is still in use for 9 snapshots
[0:02] 100.00%  9 / 9 snapshots

searching used packs...
{<data/4ac89084> <data/4e3fd177> <data/65c364ef> <data/a61dca20> <data/b56a120e> <data/e8c54897>} not found in the index

Integrity check failed: Data seems to be missing.
Will not start prune to prevent (additional) data loss!
Please report this error (along with the output of the 'prune' run) at
https://github.com/restic/restic/issues/new/chooseFatal: index is not complete

Backups seem to run fine and I am just wondering how to re-create the data files to avoid this error going forward.

Addendum, when I run restic check then I get another fatal error…

using temporary cache in /tmp/restic-check-cache-180987829
repository 2527be8c opened successfully, password is correct
created new cache in /tmp/restic-check-cache-180987829
create exclusive lock for repository
load indexes
check all packs
pack af40fb6d: not referenced in any index
pack eedcf3db: not referenced in any index
2 additional files were found in the repo, which likely contain duplicate data.
You can run `restic prune` to correct this.
check snapshots, trees and blobs
error for tree f927ac79:pshots
  tree f927ac79: file "filename.xls" blob b56a120eba883f6c0e3a0904f1b3e1a0c05b66996fdedbc780aefd339940cc06 not found in index
  tree f927ac79: file "filename.xls" blob 65c364eff6349283c93aa06d82cb0db54dc6bd4d2a36d40fbcf727324134abb9 not found in index
  tree f927ac79: file "filename.xls" blob 4e3fd1770ca3211aaaa5f3cbd4fd552bfe0cb2d42b41160ca9a025d3fa88ae59 not found in index
  tree f927ac79: file "filename.xls" blob 4ac890842be844fd7b97fd0dd7ffedbf99b4b795336c3af774783015445eaf63 not found in index
  tree f927ac79: file "filename.xls" blob e8c54897bafa7bce3a4dedc30be1faf4d2ccad2580e51b8615baa5a7dd5fce3f not found in index
  tree f927ac79: file "filename.xls" blob a61dca2091cc3c1963305e87f08dff855829276cc00489b55ef2c6651114926a not found in index
[2:59] 100.00%  9 / 9 snapshots
Fatal: repository contains errors

Mhh - you have blobs that are missing in the index. Did you run a rebuild-index in the past? If yes, this could mean you had lost pack files. If no, you lost index files.

In any case you should try to find the root cause for this loss. If this occurs again, you might lose the data in your backup that you desperately need…
It might be also an undiscovered bug in restic, in this case tracking this may not only save you but also other users!

To bring back your repository in a good state: As you use 0.12.0, you just need to run a backup that contains the file "filename.xls". This will automatically heal your repo. After that, prune should run and clean everything up.

the weekly backup task ran and after a prune; I am no longer getting this problem any more. Will keep an eye out and if see again then figure out to repro so can hunt down bugs