Not finishing backup

Hi all,

I’m trying to backup some folders from my Windows 10 computer (about 3-4 TB video/picture/docs) with it’s mounted SMB network drive (B: from a raspberry pi) (maybe 2-3 TB video/pictures) to a USB hard drive. There is a lot of duplicate files between the network drive and the local ones.

It looks like everything going great and I can even see it go through the files on the network drive, but it stops at 74% percent:

[2:33] 73.85%  986541 files 4.769 TiB, total 1091311 files 6.458 TiB, 0 errors ETA 0:54
[2:33] 73.85%  986601 files 4.769 TiB, total 1091311 files 6.458 TiB, 0 errors ETA 0:54

Files:         400 new,     0 changed, 1090911 unmodified
Dirs:           28 new,     6 changed, 96077 unmodified
Added to the repository: 110.330 KiB (37.731 KiB stored)

processed 1091311 files, 6.458 TiB in 2:39
snapshot ac1ac908 saved

I tried to Google and search this forum but can’t find anything.

What could it be?

I run it from Windows PowerShell (include.txt is just a list of folders and password.txt contains the meaning of life):

restic -r G:\Jalte\restic-backup backup "C:\Users\J_stationaer\Documents" --files-from="C:\restic\include.txt" --password-file="C:\restic\password.txt"


restic 0.15.2 compiled with go1.20.3 on windows/amd64



Judging from the output the problem is just of cosmetic nature. As there are only 6 seconds between 74% and 100% it’s likely that the following happened: The last 2TB and the remaining files might all be part of a single folder and therefore just show up all at once.

1 Like