No space left on empty drive/partition

Hey Gang-

Been using restic thru wasabi/s3 for snapshots the last year or so. Borked my system so need to restore a snapshot for the first time. My home dir is empty (1.8T) and the original saved dir is around 500GB. All snapshots are intact remotely.

When I try to restore the latest snapshot, I get the error, “no space left on drive, ~/.cache/restic/”. I opened up all permissions thinking that was it but no luck. Also googled web and this site.

Thanks in advance.

I should have mentioned above using ubuntu 23.04 live usb drive to run it and restic 0.14. Switched to ubuntu 22.04 and seems I am getting the same error. Looks to be processing but if I cancel I get a stream of ‘device full’ issues.

Please check out this page. Maybe you can try setting a different cache dir (e.g. on the target drive) or disable caching entirely?

Disabling caching will drastically reduce the restore performance. Just pass --cache-dir /path/to/a/disk/with/sufficient/free/space to restic.

Thanks for the tips. Adding a cache (which was wiped out when /home was originally corrupted and reformatted) returned a response. I also realized that I had not pruned since inception so had 190 snapshots which I reduced significantly. A restore is now running but I am currently getting a lot of “permission denied” errors, that for now, look to be .git repos stored locally. So I am not confident.

I am really at a loss after looking around for solutions and coming up empty.

That should only happen if you restore to an already existing folder. Please restore to an empty folder and move everything back into its place afterwards.

Thanks for the follow-up. For some reason, I could not do a full restore to a new location (VPN, excessive transit times, SE-Asia<–>US West coast server). I didn’t document why not, i.e. bunch of erros, but I have resigned myself to mounting the dd saved image and shuffling things back to original place. Will keep digging in to learning restic though.

FWIW: I was ‘stuck’ on version 0.14 using ubuntu 23.04 and was able to upgrade to 0.16 using restic’s self-update feature. That wasn’t immediately obvious to me in the beginning.

I will close for now as it is reasonably solved.