Nightly backup stopped working after a few uses

journalctl -u restic-backup.service -b
unable to open cache: unable to locate cache directory (XDG_CACHE_HOME and HOME unset)
among other things–which all look OK.

This means nothing to me…anyone know what this means?

This means your systemd service is being run with HOME unset, which seems a bit weird to me. Anyway, you could fix it by creating a directory for the restic cache (maybe in /var or /tmp), making sure it’s owned by the user that systemd runs restic as, and then setting XDG_CACHE_HOME to that directory in the systemd unit. (Environment="XDG_CACHE_HOME=/path/to/cachedir")