Local backup is changing the host name

Hi all,
I do restic backups for around six weeks hourly with:

restic -r /mnt/backup/homebfe --verbose --exclude /home/bfe/Downloads --exclude /home/bfe/.cache --exclude /home/bfe/.local/share/Trash backup /home/bfe

and it works nearly great. I backup my home directory and the backup is on a additional disk inside my computer (no network, no USB…).

restic -r /mnt/backup/homebfe snapshots shows:

ID Time Host Tags Paths
7e7de4c0 2020-12-31 18:30:01 localhost.localdomain /home/bfe
5c601b99 2021-01-16 19:30:01 linux.fritz.box /home/bfe
208d695a 2021-01-17 22:30:01 localhost.localdomain /home/bfe
df2ab85a 2021-01-23 16:30:01 localhost.localdomain /home/bfe
0dafca51 2021-01-23 21:30:01 linux.fritz.box /home/bfe
1ec1363d 2021-01-26 18:30:01 localhost.localdomain /home/bfe
08d2a687 2021-01-29 19:30:01 localhost.localdomain /home/bfe
9a5d6b13 2021-01-30 22:30:01 localhost.localdomain /home/bfe
66992108 2021-01-31 16:30:01 localhost.localdomain /home/bfe
829eaf13 2021-01-31 18:30:01 linux.fritz.box /home/bfe
089f5af5 2021-02-01 17:30:01 linux.fritz.box /home/bfe
de104ecf 2021-02-01 23:30:01 localhost.localdomain /home/bfe
67896033 2021-02-02 16:30:01 localhost.localdomain /home/bfe
0fbf5863 2021-02-03 18:30:01 localhost.localdomain /home/bfe

the problem is that the hostname is changing between linux… and localhost…

the --prune command doesn’t work with different hostnames.

My work around was to delete the localhost… backups by hand but this is no solution

I run Fedora33

Is there a way to write the hostname in the restic command?

Any ideas


You could either set the hostname explicitly when running a backup by using the --host flag or adjust the forget command to use a different ‘group-by’ strategy (e.g. --group-by paths,tags).