Listing snapshots causes hang in terminal

I’m not sure when this started happening, but it’s a recently development.

When I run “restic -r <remote repo, backblaze s3> snapshots” the command just hangs and does nothing. I could let it go for an hour and nothing will appear in the terminal. Also this is an S3 compatible bucket so that shouldn’t be the issue.

I tried updating the system and rebooting but nothing…

This honestly doesn’t sound like a restic problem sorry.
Does the host have working DNS etc?
What happens if you try this from another host?

I expect you’ve got a network issue, like an MTU problem, or similar.

Hi @Mailstorm and welcome to the restic community! :slight_smile:

Do you know if any other repository commands work? For example, are you able to create new snapshots?

What version of restic are you using?

It’s not DNS as I can ping the s3 bucket no problem. It was working once before but has since stopped.

Yes I can run a backup just fine and it will complete if there’s something to do.

Between my last post and now I found out what was wrong. My environment variables weren’t loading so it didn’t have the access secret, key, or password. So I’m just an idiot that’s all

1 Like