How to use --s3-no-check-bucket to initialize a repository?

Sorry if this is a very stupid question but I know what flag to use but not how to use it.

I need to change this

restic -r rclone:mybackup:mybackup init

to use the flag --s3-no-check-bucket

but any of

restic -r rclone:mybackup:mybackup --s3-no-check-bucket init
restic -r rclone:mybackup:mybackup init --s3-no-check-bucket
restic -r --s3-no-check-bucket rclone:mybackup:mybackup init

they give me error.

How to set --s3-no-check-bucket init ?
I need that flag to be able to have different buckets with different keys in iDrive e2

If access key does not have all buckets access

type = s3
provider = IDrive
access_key_id = iOWVPj23cQdLzkxmO6jo
secret_access_key = z1TZYjiP1goYrtzfyyKyBfRN5O1sghNcX1xKn0R2
endpoint =  
no_check_bucket = true


Rclone checks for bucket creation permissions when uploading files:

  • If access key does not have ALL buckets access, you must add the following to your configuration (As the limited access key does not have bucket creation permissions): no_check_bucket = true Optionally instead of the config line, you may use the following flag: --s3-no-check-bucket

The easiest is to use environment variables to set specific rclone flags - Documentation

In all operating systems you can either set them globally or only for specific restic command runtime.

1 Like

Oh no! So simple!
You gave me the clue. I simply edited the rclone.conf file and added it to the repository the line
no_check_bucket = true

Thanks so much

1 Like