Help using restic with minio

Hi all,

I have a minio server up and running on (Port 443). I can use the minio web ui to create buckets, upload and download data.

Now I want to use it for restic like so:
./restic -r s3: init

The bcket restic doesn’t exist. But all I get is an error:
Fatal: create repository at s3::443/restic failed: client.MakeBucket: The specified bucket does not exist.

restic 0.8.3 (v0.8.3-52-g4a524da)
compiled with go1.9.4 on linux/amd64

Seems like I’m doing something wrong, help is appreciated, thx!


Hi, and welcome,

You say that the bucket does not exist. The error message tells you the bucket does not exist.

Have you tried creating the bucket and running the init again? If yes, what’s the result of that?

PS: Did you remove the hostname in the error message, or is it really not there? It’s hard to tell.

PS: Did or can you try it with HTTP instead of HTTPS?

Thanks :slight_smile:

It is the same error, no difference if the bucket is manually created beforehand or not. Yes sorry I forgot to copy the domain in the error message, it is printed in the error message as well.

Fatal: create repository at s3: failed: client.MakeBucket: The specified bucket does not exist.

Where can I dig to get you more information?


You can try creating a debug log, instructions on how to do that are here:

It should also contain the raw HTTP requests and responses issued to the Minio server, we can then take a look what’s going on.