Forget --prune command doesnt seem to work if you specify a policy

/usr/local/bin/restic --cache-dir /mnt/external/restic_cache/ --json -r forget --keep-hourly=60 --keep-daily=30 --keep-weekly=52 --prune

Doesn’t seem to work, it just lists the snapshots as if you had just specified forget without the --prune flag.

Can someone verify this. If its a problem ill raise an issue.



Quoting the help:

--prune  automatically run the 'prune' command if snapshots have been removed

Passing --prune to forget will only run prune if snapshots have been forgotten. Is that the case? restic tells you which snapshots have been forgotten in the output.