Error: "<key/8d7cd73b2f> does not exist"

Hi there
I am testing restic with rclone on an AWS Lightsail server to backup to AWS S3.

I can, however, create a repo, but not backup anything:

bitnami@ip-111-222-333-444:~$ restic -r rclone:awss3test:server-awsligthsail backup --verbose ~/test_for_backup
/
open repository
enter password for repository: 
Load(<key/8d7cd73b2f>, 0, 0) returned error, retrying after 720.254544ms: <key/8d7cd73b2f> does not exist
Load(<key/8d7cd73b2f>, 0, 0) returned error, retrying after 873.42004ms: <key/8d7cd73b2f> does not exist
(…)

Have removed the repo multiple times and init has no errors. Looking into the S3 bucket I see there is a config file and a keys folder.

ubuntu 16.04
restic 0.12.1
rclone 1.57
S3 IAM has AmazonS3FullAccess
Testing from another server I get the same error. Have no idea what the propblem is. My bucket has nothing special (no versioning, no tags, region is correct, …)

Since the config file is put into S3 write access is ok. Any idea what is wrong?

Hey @suntrop and welcome to the Restic community! :slight_smile:

So I don’t know how up to date these docs are in terms of the Amazon side of things for the UI, but it might be good to look at them and check: Examples — restic 0.12.1 documentation

Unfortunately I don’t use Amazon’s S3 service so I couldn’t give you pointers.
One thing I see right away is that you use rclone with in combination with Restic - you don’t have to do that, though it works as well. Restic can work with S3 out of the box.

Just doing a quick Google search, I came across this post: Fast and Secure Backups to S3 with Restic | by Dennis Webb | Medium maybe you can find some details there which might help you solve your issue. :slight_smile: (in case no one from the community chimes in :wink: )

Hi :wave:
Could you check if the specified key exist under keys folder in the bucket?

Thanks for answering guys!

@moritzdietz
I read the example setup for S3 in the docs. The first part (S3) is almost the same like I did it. Since I use rclone, I haven’t done the second part. Will try if it works later today!
Have decided to pair restic and rclone in November. Cant remember the exact reason :woozy_face:

@gurkan
The error message is about files “key/8d7cd73b2f” but first there is no folder key. In S3 there is a folder “keys” in plural. And there is just one file “8d76n73b2fedbf5b3d48b1baf47fc0f2c5cfa28c8276ca6066e94dd8degw9e1b”

I just noticed something else.

$ restic -r rclone:awss3test:server-awsligthsail/testfolder snapshots
… asks for my repo password. No matter what I type, I get the errors (Load key/dfds7fzdf65 etc). I have deleted the repo and made a new one. Same again. So I even can’t list anything.

However, rclone seems to be configured correctly:
$ rclone lsd awss3test:server-awsligthsail/testfolder
… will list a folder “keys”

So there is something wrong with the restic repo itself!?

Are you able to download the problematic file in the keys folder manually using rclone?

Did the key name change after recreating the repository?

@MichaelEischer
No, nothing seems to work using restic with a rclone backend.

Both work on its own fine. rclone and restic (with nativ S3 config) have access to the files. But no matter what I do, I get the same error when I combine them.

Does rclone print anything helpful when adding -o rclone.args="serve restic -vv --stdio --b2-hard-delete" to the restic command line? The difference to the normal parameters is the -vv to let rclone print debug information on what is going on (Documentation)