Dokany mounted filesystem inaccessible in Windows

We use Cryptomator with a Dokany mount point to access encrypted files on Google Drive. The Dokany mount point is located on the local file system. Normally, we can access the mounted directory and all its files using all Windows software. But not with Restic.

Are there any tricks I’m missing for this?

Here is a transcript:

PS C:\Users\Chris\Robust\Backup> restic --repo '\\ccnas\Backup\Robust\restic\' snapshots
enter password for repository:
repository d847d773 opened successfully, password is correct
ID        Time                 Host        Tags        Paths
1fa6983b  2021-11-18 15:22:18  CCI7                    G:\
55269012  2021-11-19 11:54:59  CCI7                    G:\
4ab6ef65  2021-11-20 19:21:09  CCI7                    G:\
6c53a373  2021-11-21 18:55:00  CCI7                    G:\
04e9ec94  2021-11-29 20:36:06  CCI7                    G:\
3e3b5295  2021-11-30 11:42:42  CCI7                    G:\
6 snapshots
PS C:\Users\Chris\Robust\Backup> restic --repo '\\ccnas\Backup\Robust\restic\' backup 'C:\Users\Chris\Robust\Client\UofT\'
enter password for repository:
repository d847d773 opened successfully, password is correct
no parent snapshot found, will read all files
error: NodeFromFileInfo: Readlink: readlink \\?\C:\Users\Chris\Robust\Client\UofT: The system cannot find the file specified.

Files:           0 new,     0 changed,     0 unmodified
Dirs:            5 new,     0 changed,     0 unmodified
Added to the repo: 0 B

processed 0 files, 0 B in 0:01
snapshot 3ad32299 saved
Warning: at least one source file could not be read
PS C:\Users\Chris\Robust\Backup> ls 'C:\Users\Chris\Robust\Client\UofT\'

    Directory: C:\Users\Chris\Robust\Client\UofT

Mode                 LastWriteTime         Length Name
----                 -------------         ------ ----
d-----        2012-07-28  10:03 AM                Case
------        2010-03-11  12:05 PM           6210 UofT.bmp
------        2010-03-11  12:03 PM           1541 IMG_0019.JPG
------        2010-05-07   9:45 PM          21504 Notes.xls
------        2010-05-07   9:45 PM          34304 t.doc

PS C:\Users\Chris\Robust\Backup>

Silly question perhaps but can you verify that the 'C:\Users\Chris\Robust\Client\UofT\' part doesn’t contain any funky hidden characters, e.g. by typing out that part of the backup command manually/by hand? We’ve had cases where there’s been hidden characters in filenames, causing scanning issues.

I can confirm that the commands above were actually typed by hand (so no hidden characters), but I have tried this several different times with and without a script. I’ve tried backing up both a sub-directory and the parent directory of this folder. When backing up the parent directory, restic hits this folder with the same error message.

Sounds like this issue:

1 Like

It does sound a lot like that issue, I agree.

But, they fixed that issue in Dokany version 1.0.3 and we are currently running which includes that patch - 4860b95daaadfef3da9233509ac8bb29a7743b95

It still could be a Dokany issue, but I’m wondering if I should also report it as a Restic bug.

The problem looks a lot like error: NodeFromFileInfo: Readlink: readlink \\?\C:\ProgramData\restic\shadow\C: The parameter is incorrect. · Issue #2708 · restic/restic · GitHub to me.

Yes. I think you found it. That looks like the problem I’m getting. It sounds like this is a restic bug and not a user issue. Thank you.

The issue has been reported as a bug in restic #3594.