Control characters in stdout when running in W10

Firstly, thank you! restic is fantastic.

I’m running my first scripts in W10. When I run the following at the command prompt:

restic -r “E:\backups\restic\test” --verbose -p “D:\My Documents\sysadmin\Resources\restic\test_pwd.txt” backup “D:\My documents\doc\test”

… the output is normal. But in a Python script, if I do this:

pwd_file = r'D:\My documents\sysadmin\Resources\restic\test_pwd.txt'
restic_result = subprocess.run(['restic', '-r', fr'{drive}:\backups\restic\test', '--verbose', '-p', pwd_file, 'backup', r'D:\My documents\doc\test', ], 
    stdout=subprocess.PIPE, stderr=subprocess.STDOUT, timeout=60)
print( restic_result.stdout.decode( 'utf-8' ) )

… I get what I think are colour control characters at the start of the lines:

open repository
←[2Klock repository
←[2Kload index files
←[2Kusing parent snapshot 07832b0b

NB this control character is really “\x1b[”. This may well be a Python subprocess question rather than a restic question, but do you know if there is any way to omit these control characters? NB with ls the switch --color=never apparently suppresses them. I tried this with restic backup but got “unknown switch”…

This bug is being worked on, thanks for the report!