Config file missing from my B2 bucket

I tried to do my weekly backup this morning to find my config file is missing from my B2 bucket

Restic now complains

Fatal: unable to open config file: Stat: b2_download_file_by_name: 404: File with such name does not exist.

Is there a repository at the following location?

I have tried restic check --no-cache
and also tried to init a new repo with the same password and then dragging the config over to my original bucket but still no luck. Are my backups gone and will I have to upload everything again?

can’t understand what has caused the config to disappear.

Did you check that the file is really missing, using other tools to look into your bucket?

If the file is not there and you don’t have a copy of it, I’m pretty sure that you will not be able to access that backup repo, since some encryption parameters are stored inside that file.

Yea I’ve checked with Cyberduck and also the b2 web client and it’s definitely not there. I’ve nuked the files and started a new back up and I’ve already done a backup of the config file and put it some where safe so it doesn’t happen again.

Don’t know how it got deleted cause I never access the b2 bucket with anything other than restic

Okay, that’s too bad, and yeah that’s very odd. I am not aware of any circumstance where restic would delete the config file, it simply doesn’t make any sense to do so. Also, the backup command just adds data to the repo, it doesn’t delete anything. It would perhaps be good if you asked B2 what happened to your file, but if you already messed with the bucket I guess they have little to go on.