Ciphertext verification failed, ignoring

Backing up to Backblaze B2, I’ve been getting this error. What is the cause of this error. Should I be concerned?


Additional data:
I ran the restic check on the repo. The error I received back is as follows:

password is correct
create exclusive lock for repository
load indexes
error: error loading index 870245f5: ciphertext verification failed
Fatal: LoadIndex returned errors

Do I need to scrub this repo and start over?


It sounds like the file was modified, possibly in transit. Can you manually download the file in question? It is located in the index folder, and the name starts with 870245f5.

When you got the file, run sha256sum on it, and compare the resulting hash with the filename. If it’s something different, the file was modified. That’d also explain why the signature on the file is invalid.

@skipchang Did you ever follow up on @fd0’s suggestion? The same thing has been asked in Ciphertext verification failed during restore, `restic check` found no errors and I’m just curious.

The cause of your problem is likely what @fd0 said, the file in your repository was for some reason modified (not by restic, so you might want to check your hardware).

I’m looking to mark this thread as solved, but would like to hear how it went for you first.