Can't list rclone repository

I’m trying to list a repo using rclone but nothing happens, I get this:

>restic -r "rclone:REMOTE:PATH" --verbose list snapshots
repository xxxxxxxx opened successfully, password is correct

I’m using the wrong commands or listing using rclone is not supported yet?

Does it stale then or does it return to the prompt? If the latter, have you checked the exit code?

Thanks for the help, it returns, even though I used --verbose I didn’t get anything else. Now I’m thinking maybe it returns nothing because I Ctrl+C’d the previous backup operation though I thought it would show up the files restic was able to backup during the days the operation was running.

Now I’m getting another problem. I started another backup (another directory) using the same commands as the first backup I did but had to cancel it because I wanted to log rclone too and now I keep getting an error that says

Fatal: unable to open repo at rclone:REMOTE:restic: error talking HTTP to rclone: Get "http://localhost/file-XXXXXXXXXX": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

I tried several times and even restarted the system to no avail.
What does works is serving the remote using rclone with:

rclone serve restic REMOTE FLAGS

And then using restic with:

restic -r rest:http://localhost:8080 DIR FLAGS

So I don’t know what is happening. I tried snooping the open ports on my computer while executing restic and the port 8080 was being used so rclone did serve, I don’t know why it times out.