Blob not remove with Rest Server

Excuse me, I have a windows pc with a folder, and a linux machine where stay the backup. I use Rest Server and when I use the powershell script:

restic backup -r rest:http://resticuser:serverpassword@ D:\myfolder --cleanup-cache --verbose --verbose

restic forget --prune --keep-daily 7 --keep-monthly 12 --keep-yearly 3 -r rest:http://resticuser:serverpassword@

the backup are ok, but I receive more of these:

Remove(<snapshot/026a010db0>) returned error, retrying after 720.254544ms: blob not removed, server response: 403 Forbidden (403)
Remove(<snapshot/1d99f80bcd>) returned error, retrying after 873.42004ms: blob not removed, server response: 403 Forbidden (403)

I tried to run the same command on linux server:

restic forget --prune --keep-daily 7 --keep-monthly 12 --keep-yearly 3 -r myfolder

and so it works. How I can solve?

Presumably you have incorrect permissions on those files on the Linux server. Make sure that all of the files and folders are read- and writeable by the user that rest-server runs as.

I set the folder recoursive with chmod 755, but nothing

Not really sure what to say. REST-server just tries to read and write those files. If it fails to do that then you need to look closer at the permissions etc. Have you for starters verified that those snapshots exist in the snapshots/ folder?

some time ago I did the check of screenshots. After that episode I had to fix the permissions, because it couldn’t make backups. It can be related to that?

It’s a bit unclear what you mean. Again; Verify that the files mentioned in the error message are actually present, then check the permissions on those files and the folders as well.

Also, make sure that you are really running the latest versions of rest-server and restic, they are available here: Release v0.11.0 · restic/rest-server · GitHub and Release restic 0.12.1 · restic/restic · GitHub

A 403 error from the rest-server looks like it was started using --append-only. While that flag is active, it’s obviously not possible to delete data.

I have not used the append command

Which rest-server version do you use? How do you start the rest-server?

For somewhat recent rest-server versions, the --append-only flag is the only way to cause a 403 error. So the error is either caused by that flag, a very old rest-server version (just maybe, haven’t checked those) or there is some proxy/webserver running in from of rest-server which forbids deleting.

My version is 0.9.6. How I can update without problem on linux ubuntu?

You can download the prebuilt binary from github and put it into /usr/local/bin/ .

I installed restic with scoop. Can I do it anyway?

Yes. The rest-server program is just one single binary/executable, which means that you can put it anywhere you want and run it, it really doesn’t care where it is placed/located on your file system.

What you want to make sure however is that when you have downloaded the latest rest-server release, and you run it the usual way, the copy you downloaded is the one that is actually being used (instead of the old one you installed via scoop).

I would suggest that you uninstall the one from scoop to make sure that you don’t accidentally execute that instead of the new one you downloaded from the link above.

Ok, thank you