"This is non-critical, you can run `restic prune` to correct this."


Newbie here.
Running backup every hour of a disk to cloud storage since about a month. Did some thoughtless changes to the cloud directory structure a few days ago which now is reverted. Obviously that did not went well for the backups. So did a “check” and it says “This is non-critical, you can run restic prune to correct this.”.

Read some docs on how and what to prune and tried various things related to tree ed87ada4 and id ed87ada4c01ad47f63384b0bf99bd900550e3e43faa64a74a6819f6002b63405. I’m quite sure I don’t really understand what the result of the check command means an how to deal with it.

Any help appreciated.

Restic 0.14.0 compiled with go1.19 on windows/amd64

Full check result below.

restic -r Z:/backup check
using temporary cache in C:\Users\X\AppData\Local\Temp\restic-check-cache-668951241
enter password for repository:
repository 9c5f723f opened (repository version 2) successfully, password is correct
created new cache in C:\Users\X\AppData\Local\Temp\restic-check-cache-668951241
create exclusive lock for repository
load indexes
check all packs
pack 10276e9bf3e2cbeb5fed0f4f2d00fd78d68af7f909edd13873850c6f312b0cca: does not exist
pack 40fd7c9058ea5e46354535a7184dd91dd9b2f8f9aee5658b43af63f444f8c090: does not exist
pack 645873558a3de8ee7a055098803dfd9b42c483513d1e8dcf20f56b69528a105a: does not exist
pack 3c55023a96b48ecf7d81c0d9b1f4db7cb9aed28c7e51fcf3bc898ff0d6c9caa1: does not exist
pack ff67e6e67d3ca2970c69b6a19ba9fb02fd4e4f9828daa1afeced9512ef21236d: does not exist
pack 70defc0ba76e540560c9963e84fd890612aa00f73a1479341f094e7b5fcf13dd: does not exist
pack ae03be7e4eed1f1eae81d1f2091ba1fd7dad1e4d5c1ec1af8b90c8882299cbca: does not exist
pack c13119a22cbc6ff53b9d0eda12d7720d004f616667b1fe0f386c6d08e3fc9f0f: does not exist
pack cd3731f1e161e67dffec572ae1dbafc1e5d13e7662be04f8d7894d50369587e1: does not exist
pack fb00f2ea8ca34976e68c235de602bea00ff4246088e2da4a7f6d3ef241ca364a: does not exist
pack 773d2027534351b40a8d1c6e3e7edaee01f80d5e9c3ee93130584b90b1e93a72: does not exist
pack 3d3c498b2a4a8cba2adc8df99130781534dcc32fe874a4ae31a1c526e06e1a13: does not exist
pack 8e8005d737fd3e16b499631d966feacbfe88b18cd7860cdf1a1fa283ee872226: does not exist
pack 406fe57d437d06eb8d9e241ceaa673aabdeda73330215164715c8c5198389edc: does not exist
pack 548c59c662bdf2ec9b10d16247b43cd8f46debcf455e50475fdc5aa285fdabf9: does not exist
pack 36cc90d702c772c051aa6741eebc500872961f65391676aa537c81d957cfc4db: does not exist
pack 5b5216cc47e5a56f77756d421d60ea33f5749ae0cdf26005a7b350e68cfe3a04: does not exist
pack c378fa925225b4f7d82396f09524c884b4e26f68e12994f9b17db2a247b4e8db: does not exist
pack 1a2789e48e53d85af5ce9f6e3c4445183577942127cdc014ab7fb44279f02787: does not exist
pack cc1e664745690763ebda4ac03741a3b45e0ca73e76f85a2ce094f7f9982d7f5b: does not exist
pack 0065d6a70cb9196f0bd0fffa4c384a8b878b4dc6db4062171039b26e4b41e11d: does not exist
pack a88c02739b037be5f81085ddde677f31cec47904cf11391599117747aaca82e8: does not exist
pack 908f8ca7b1e6fb783ab2be27f7e54355bb39e322dbf791c1f3fc49952ca4ec7f: does not exist
pack 11f5e2e305d32b8cc9bc653c70e1250d4066367e91ac984432e9768095b26f64: does not exist
pack 8e22ba3d517db821b2a339e0d7d0d3f221cb78ed3d80f45ee7725be0a1e7c568: does not exist
pack 2c9758e87896865abf1f687f707a625dfffafe7570d35f776714976dfdec749a: does not exist
pack b462060291c45ba94203ee2a7c323717015bd1b8bd9e50d1fa81c3a1a0c3d83b: does not exist
pack 4b1bf356cd08bd73082badeaa36821b3373c751c7fc833138ae9f8a02f97eec2: does not exist
pack 934cf1ef9ec3181cb026db3eb939c8c3acce2e8710b72b93f8bcb6c77d361451: does not exist
pack 5cc22c32855810f208fb4f9fd73e83ecab51ad34d64647df2e9de5f092ab7c0c: does not exist
pack d06e123676f3b8437edf5c99f1578dff8a3831ed6161b9666ffc29b98c4c612d: not referenced in any index
pack 7b4d43bec3cee13cec5d5351f8332675eb990b29494de33b4e0929c96a1e9645: not referenced in any index
2 additional files were found in the repo, which likely contain duplicate data.
This is non-critical, you can run `restic prune` to correct this.
check snapshots, trees and blobs
error for tree ed87ada4:snapshots
  id ed87ada4c01ad47f63384b0bf99bd900550e3e43faa64a74a6819f6002b63405 not found in repository
[2:01] 100.00%  125 / 125 snapshots
Fatal: repository contains errors

Only the not referenced in any index packs are non-critical, the packs which don’t exist are critical.
Actually the output is very misleading…

Ok, so what are my options?

The first step is to run rebuild-index to let restic update the index such that it matches the repository again. Afterwards you can try to follow the steps from Route 2 in Recover from broken pack file · Issue #828 · restic/restic · GitHub .

1 Like

Thank you! Worked like a charm.
“no errors were found”