Snapshot got killed during backup, what happens?


my running snapshot (1Million files, 2Tb) got killed at about 70% during the backup (kernel crash, nothing to do with restic) and system rebooted.

After reboot, i run restic snapshots but that snapshot was not found (not on the list), still, S3 bucket has files in it about it as it’s size increased for the same amount of data.

Whats happened?

Can i resume it if i run the same command, will restic recognize the files and start from that point?

If not, and snapshot needs to restart from scratch, how do i clean the bucket? (other snapshots in it, for other paths).


TL;DR: Yes, you can simply run the backup again and it will pick up where it left off, and in the end create a snapshot.

What happened was presumably that you started a backup, restic uploaded new/added data for as long as it could, then it was interrupted. Since it was interrupted, it never finished the backup, and this means that no snapshot was created (the snapshot is created as the last step in the backup process, when all of the data the snapshot should reference is uploaded).

It’s all fine.

1 Like

Cool, thanks :blush:

Note that resuming from the backend side perfectly works. If you restart the already saved data (to be more precise: most of it) will be reused and more or less only the missing data is added to the repository.

From the backup source side, however, there is no resuming implemented so far. That means all your files-to-backup will be re-read, chunked and hashed again before restic finally recognizes that most data is already present. So this “resumed” backup may still be CPU-intensive and heavily reads on your source data and therefore may still take some time to finish.

For most settings, this is fully acceptable.

There is an experimental PR which also adds a “full” resume with respect to the source side:

Good to know, thanks :+1: