Restore problems


#1

I’m trying to restore from a 50GB dataset but I run into problems:

$ restic -r restic check
password is correct
create exclusive lock for repository
load indexes
check all packs
check snapshots, trees and blobs
error for tree [null]:
  tree 0000000000000000000000000000000000000000000000000000000000000000 not found in repository
Fatal: repository contains errors

rebuild-index runs without errors:

$ restic -r restic rebuild-index
password is correct
counting files in repo
[0:00] 100.00%  11306 / 11306 packs
finding old index files
saved new indexes as [34a12efa 8cbd563c d24b20b9 f5dc29de]
remove 4 old index files

I’m at a lost what the next steps are for my to try :frowning:

The backups were made using version 0.8.3. I’ve tried the current version 0.9.3 as well as the other one without success.


#2

Huh, interesting! You found a bug, thanks for the report! :slight_smile:

Restic’s data structure consist of trees (directories) which have nodes (files, dirs). If a node is a directory, it references another tree by its ID. In this case here, the ID is null (which is invalid, so it cannot be found in the repo). This should not happen, ergo it’s a bug. We now need to find out what exactly is wrong, how to reproduce it, and then we’ll add code (and tests) so that it does not happen again.

Would you mind filling out the issue template so we can track it?

The next steps are (roughly):

Let’s continue in the newly created issue so it’s easier to find :slight_smile: