Restic Connection to B2 Wont Init repository due to 401 error

First time Restic user here. I am attempting to use the Lobaro docker container using docker compose. I am unable to get Restic to init the repository in my Backblaze account, I get a 401 error. I initially assumed I had to have the wrong ID/Key pair, so I created a new one and tried those, then another new one, then tried my master ID and key. Nothing seems to change the error. I am hoping maybe I am just doing something wrong, and someone will spot it. Here is the docker compose file I am using with the ID and key changed of course.

    container_name: restic
    image: lobaro/restic-backup-docker:latest
    hostname: dockerserver
      - RESTIC_REPOSITORY=b2:TomsResticBucket:restic/dockerserver
      - RESTIC_PASSWORD=1234
      - RESTIC_TAG=1234
      - BACKUP_CRON=0 0 * * *
      - RESTIC_FORGET_ARGS=--keep-last 10
      - B2_ACCOUNT_ID=<mymasteraccountidhere>
      - B2_ACCOUNT_KEY=<mymasteraccountkeyhere>
      - configdrive:/data/configs
    restart: unless-stopped

This is the error I am seeing inside the contianer:

Starting container ...
Check Repo status 1
Restic repository 'b2:TomsResticBucket:restic/dockerserver' does not exists. Running restic init.
Fatal: create repository at b2:TomsResticBucket:restic/dockerserver failed: b2.NewClient: b2_authorize_account: 401: 
Repo init status 1
Failed to init the repository: 'b2:TomsResticBucket:restic/dockerserver'

Any help is appreciated, thanks in advance!

I personally don’t use B2, but I’d suggest trying the S3 backend, although unlikely to be different, just for kicks. B2 has an S3 compatible backend. Please see the Warning notice here for a little more information: Preparing a new repository — restic 0.14.0 documentation

Judging from the B2 documentation, the 401 error is probably caused by “The applicationKeyId and/or the applicationKey are wrong.” Please double check those.