Pack file cannot be listed: ciphertext verification failed

Hi all - I’m having an issue with restic and wonder if the community has any thoughts on this. While running restic prune (version 0.9.4), I’m getting a lot of messages like:

pack file cannot be listed b28fd05981578bb98f9c22f3c60c4ec650d9687c8847aa8a568682f9c1390dab: ciphertext verification failed

The situation leading up to this was that my Nagios monitoring alerted because restic hadn’t run in a while, and I noticed there was a stale lock in the repo (which is on B2). I ran restic unlock, which worked. I figured that probably the last backup had been interrupted or something. So I ran restic prune with the notion that it would clean up any packs that the interrupted backup had created.

During the prune, I got dozens or hundreds of these messages, each with a different hash. They are not fatal - the process is still running. What I’m wondering is, do these indicate a serious problem with my repo? If there are packs that can’t be decrypted, I’m worried about the integrity of my data. Or are these maybe just packs that were partially written during the failed backup?

Any thoughts from people with more restic internals knowledge would be gratefully accepted.



It does sound like this particular pack file is corrupted. Perhaps this happened when the last backup terminated abnormally. I would suggest:

  1. Move this pack out of the repository directory.
  2. Run restic rebuild-index.
  3. Run restic check --read-data.

If the index rebuild and check all succeed then all of the snapshots present in the repository are fully intact.