Mounting restic repo as a drive yields ... problems?

According to the documentation, in order to mount a restic repo as if it were a drive, the command should look like this:

sudo restic -r /media/restic-repo mount /mnt/restic-dir

It appears to have worked … at first. But when I get to /mnt/ I can get no further. A quick ls -la command shows me this:

ls: cannot access ‘restic-dir’: Permission denied
total 8
drwxr-xr-x 3 root root 4096 Apr 27 19:07 ./
drwxr-xr-x 20 root root 4096 Apr 27 14:44 …/
d??? ? ? ? ? ? restic-dir/

So, ya. Pretty bad news for me. I could still re-mount the old drives and recover the data, but that’s … work.
Any thoughts would be greatly appreciated :slight_smile:

::EDIT:: ==================================

Sorry, I posted this last night right before bed. I completely forgot to give some context. I’m moving everything from Kubuntu 19.10 to a fresh installation of Kubuntu 20.04.
All of my restic repos were created under 19.10. This is what I use to make my backups:

sudo restic -r /media/restic-repo backup -x /

The previous file system was ext4 as is my current filing system.

However, during Focal Fossa’s installation ( I don’t know how much this could affect this) I thought I’d activate the hardware RAID support since I just purchased a few identical drives just for the reinstall.

But - for whatever reason, the active hardware RAID support was causing a grip of other issues, so I had to turn it off. Again - not sure if that has anything to do with this - but considering the amount of issues it caused; I’m not putting it past it.

Ok - so, hopefully that fills in some of the gaps I left before.


Welcome to the forum. Which restic version do you use? As which user did you run the ls -la command? As you used sudo for the mount command I assume you ran ls using your normal user account.

restic mount uses fuse to provide the backup as a filesystem. By default, fuse only allows the user who mounted the filesystem to access it. You can pass the --allow-other flag to the mount command to allow other users to access the filesystem. It is also possible to run restic mount as a normal user (and not as root) in which case you could mount the filesystem to a directory in your home folder.

1 Like

Dude, my savior! heh
Thank you :slight_smile: That was exactly the issue.
And also - thank you for welcoming me here.
This was exactly what I needed. I guess I was so used to backing the system up with ‘sudo’ that I had not even considered this as a possible issue.

1 Like