How do I pass the value -o b2.connections=50 to the RESTIC_REPOSITORY variable

#1

When I try to assign this value to the RESTIC_REPOSITORY variable , it throws an error when running restic
export RESTIC_REPOSITORY=b2:<bucket_name>:<b2_folder> -o b2.connections=50

I tried quoting it too but doesn’t work.Is there a way I can pass this value?

0 Likes

#2

You can’t. RESTIC_REPOSITORY in in place of specifying the value of the -r option. It does not allow you to pass other arbitrary options.

And, there is no benefit to passing a value higher than 2 anyway, since the restic uploader only uses two threads currently.

1 Like

#3

Is there a way to increase the restic thread count (via some parameter or something) ?

0 Likes

#4

I don’t believe this is currently possible. It’s been requested a few times on the forum. @fd0 is this the right feature request?

0 Likes

#5

I am assuming parallelism=thread count and so the thread count is 40 and not 2? Please correct me if I am wrong

0 Likes

#6

Right, apparently this is not the correct issue. I believe this is the relevant line:

0 Likes

#7

Just wanted to add that @fd0 explained this about 2 days ago. See this thread for more information.

1 Like