Error on AWS S3 String

Hello, just trying those scripts to backup some files to AWS S3 and got this error:

[[Internet]] Repository string could not be parsed.

But the same string were used to create the respository and it worked, but when I tried to run the scheduled task in the windows task scheduler I’m geeting this error. Do you have any ideas on how to make it working??

By the way, the string that I’m using is: "

Thank you so much!!!

I never used restic with S3 so i can’t say for sure, but the syntax you have in your string there isn’t in the format that’s explained in the S3 restic docs at Preparing a new repository — restic 0.12.0 documentation . Perhaps that’s the issue?

It’s hard to diagnose your issue when you don’t provide any actual output. What does the “[[Internet]]” thing in the error message you wrote mean? Can you please make a complete run of restic and copy/paste all of the command and all of its output, so we get a clearer picture?

Hello rawtaz, thanks for replying me… As I said, I think the string is ok because I was able to create the repository using the same string but I think there is some issue in the Powershell code I’ve been using to automate my tasks and there is no issue with restic itself, I’ll check it to see if I can solve the problem and then I’ll share with you guys here, thanks a lot for now!!!

1 Like