B2 Bucket Error

Hi ,

Setup -
Macosx Catalina and restic 0.10.0. have successfully initiated the repository using a bucket with a unique name. also assign a password to the repo. I check at the b2 end ( i can see it in the b2 explorer .) edit - important to mention that in the .bash_profile only the following is populated


not using the repo password variable nor a password file yet .


but when i try backing up using the standard command

restic -r b2:[redacted] --verbose backup ~*

i get this error

open repository

Fatal: unable to open config file: Stat: b2_download_file_by_name: 404: File with such name does not exist.

Is there a repository at the following location?

i think i have messed up somewhere .

There’s probably an issue with your (redacted) B2 repository definition.

Does that mean that restic -r b2:[redacted] init has worked by not when using the backup command?

thank you for your help . it was an error in the syntax used . i too the path/to… syntax used in example too seriously . after your reply i edited the syntax and used only the bucket name and it worked .

use b2:[yourbucketname].

try fancy paths later

yes it did . thank you for the reply